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Chapter 9: Selecting and masking

If you want to apply changes to parts of an image, you first need to select the pixels that make up those parts. You select 
pixels in Adobe Photoshop CS4 using the selection tools or by painting on a mask and loading the mask as a selection. 
To select and work with vector objects in Photoshop, you use the pen selection and shape tools. This chapter covers 
pixel selection tools and techniques.

Making selections

About selecting pixels
A selection isolates one or more parts of your image. By selecting specific areas, you can edit and apply effects and filters 
to portions of your image while leaving the unselected areas untouched.

Photoshop provides separate sets of tools to make selections of raster and vector data. For example, to select pixels, you 
can use the marquee tools or the lasso tools. You can use commands in the Select menu to select all pixels, to deselect, 
or to reselect. 

To select vector data, you can use the pen or shape tools, which produce precise outlines called paths. You can convert 
paths to selections or convert selections to paths. 

Selections can be copied, moved, and pasted, or saved and stored in an alpha channel. Alpha channels store selections 
as grayscale images called masks. A mask is like the inverse of a selection: it covers the unselected part of the image and 
protects it from any editing or manipulations you apply. You can convert a stored mask back into a selection by loading 
the alpha channel into an image. 

Note: To select a specific color or a range of colors within an entire image or within a selected area, you can use the Color 
Range command.

More Help topics 
“About masks and alpha channels” on page 274

“Create and edit alpha channel masks” on page 277

“Convert paths to selection borders” on page 384

“Selection tools gallery” on page 20

Select, deselect, and reselect pixels
You can select all visible pixels on a layer or deselect any selected pixels. 

 If a tool is not working as expected, you may have a hidden selection. Use the Deselect command and try the tool 
again.

Select all pixels on a layer within the canvas boundaries
1 Select the layer in the Layers panel.

2 Choose Select > All. 
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Deselect selections
! Do one of the following:

• Choose Select > Deselect.

• If you are using the Rectangle Marquee tool, the Elliptical Marquee tool, or the Lasso tool, click anywhere in the 
image outside the selected area.

Reselect the most recent selection
! Choose Select > Reselect.

Select with the marquee tools
The marquee tools let you select rectangles, ellipses, and 1-pixel rows and columns.

1 Select a marquee tool:
Rectangular Marquee  Makes a rectangular selection (or a square, when used with the Shift key). 

Elliptical Marquee  Makes an elliptical selection (or a circle, when used with the Shift key).

Single Row  or Single Column  Marquee Defines the border as a 1-pixel-wide row or column. 

2 Specify one of the selection options in the options bar.

Selection options
A. New  B. Add To  C. Subtract From  D. Intersect With  

3 Specify a feathering setting in the options bar. Turn anti-aliasing on or off for the Elliptical Marquee tool. See 
“Soften the edges of selections” on page 263.

4 For the Rectangle Marquee tool or the Elliptical Marquee tool, choose a style in the options bar:
Normal Determines marquee proportions by dragging. 

Fixed Ratio Sets a height-to-width ratio. Enter values (decimal values are valid) for the aspect ratio. For example, to 
draw a marquee twice as wide as it is high, enter 2 for the width and 1 for the height. 

Fixed Size Specifies set values for the marquee’s height and width. Enter pixel values in whole numbers. 

 In addition to pixels (px) you can also use specific units such as inches (in) or centimeters (cm) in height and width 
values. 

5 For aligning your selection to guides, a grid, slices, or document bounds, do one of the following to snap your 
selection:

• Choose View > Snap, or choose View > Snap To and choose a command from the submenu. The marquee selection 
can snap to a document boundary or to a variety of Photoshop Extras, controlled in the Snap To submenu.

6 Do one of the following to make a selection:

• With the Rectangle Marquee tool or the Elliptical Marquee tool, drag over the area you want to select. 

• Hold down Shift as you drag to constrain the marquee to a square or circle (release the mouse button before you 
release Shift to keep the selection shape constrained). 

• To drag a marquee from its center, hold down Alt (Windows) or Option (Mac OS) after you begin dragging.

A B C D
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Dragging a marquee from the corner of an image (left), and from the center of an image (right) by pressing Alt/Option as you drag

• With the Single Row or Single Column Marquee tool, click near the area you want to select, and then drag the 
marquee to the exact location. If no marquee is visible, increase the magnification of your image view.

To reposition a rectangle or elliptical marquee, first drag to create the selection border, keeping the mouse button 
depressed. Then hold down the spacebar and continue to drag. Release the spacebar, but keep the mouse button 

depressed, if you need to continue adjusting the selection border.

Select with the Lasso tool
The Lasso tool is useful for drawing freeform segments of a selection border. 

1 Select the Lasso tool , and select options.

2 Drag to draw a freehand selection border. 

3 Specify one of the selection options in the options bar.

Selection options
A. New  B. Add To  C. Subtract From  D. Intersect With  

4 (Optional) Set feathering and anti-aliasing in the options bar. See “Soften the edges of selections” on page 263.

5 To draw a straight-edged selection border when no other pixels are selected, press Alt (Windows) or Option 
(Mac OS), and click where segments should begin and end. You can switch between drawing freehand and straight-
edged segments. 

6 To erase recently drawn segments, hold down the Delete key until you’ve erased the fastening points for the desired 
segment.

7 To close the selection border, release the mouse without holding down Alt (Windows) or Option (Mac OS).

8 (Optional) Click Refine Edge to further adjust the selection boundary or view the selection against different 
backgrounds or as a mask. See “Refine selection edges” on page 262.

Select with the Polygonal Lasso tool
The Polygonal Lasso tool is useful for drawing straight-edged segments of a selection border.

1 Select the Polygonal Lasso tool , and select options.

2 Specify one of the selection options in the options bar.
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Selection options
A. New  B. Add To  C. Subtract From  D. Intersect With  

3 (Optional) Set feathering and anti-aliasing in the options bar. See “Soften the edges of selections” on page 263.

4 Click in the image to set the starting point.

5 Do one or more of the following:

• To draw a straight segment, position the pointer where you want the first straight segment to end, and click. 
Continue clicking to set endpoints for subsequent segments.

• To draw a straight line at a multiple of 45°, hold down Shift as you move to click the next segment.

• To draw a freehand segment, hold down Alt (Windows) or Option (Mac OS), and drag. When you finish, release 
Alt or Option and the mouse button.

• To erase recently drawn straight segments, press the Delete key.

6 Close the selection border:

• Position the Polygonal Lasso tool pointer over the starting point (a closed circle appears next to the pointer), and 
click.

• If the pointer is not over the starting point, double-click the Polygonal Lasso tool pointer, or Ctrl-click (Windows) 
or Command-click (Mac OS).

7 (Optional) Click Refine Edge to further adjust the selection boundary or view the selection against different 
backgrounds or as a mask. See “Refine selection edges” on page 262.

Select with the Magnetic Lasso tool
When you use the Magnetic Lasso tool , the border snaps to the edges of defined areas in the image. The Magnetic 
Lasso tool is not available for 32-bits-per-channel images.

The Magnetic Lasso tool is especially useful for quickly selecting objects with complex edges set against high-contrast 
backgrounds.

1 Select the Magnetic Lasso tool.

2 Specify one of the selection options in the options bar.

Selection options
A. New  B. Add To  C. Subtract From  D. Intersect With  

3 (Optional) Set feathering and anti-aliasing in the options bar. See “Soften the edges of selections” on page 263.

4 Set any of these options:
Width To specify a detection width, enter a pixel value for Width. The Magnetic Lasso tool detects edges only within 
the specified distance from the pointer.

A B C D

A B C D

Updated 1 October 2009



255USING PHOTOSHOP CS4
Selecting and masking

To change the lasso pointer so that it indicates the lasso width, press the Caps Lock key. You can change the pointer 
while the tool is selected but not in use. Press the right bracket (]) to increase the Magnetic Lasso edge width by 1 pixel; 

press the left bracket ([) to decrease the width by 1 pixel. 

Contrast To specify the lasso’s sensitivity to edges in the image, enter a value between 1% and 100% for Contrast. A 
higher value detects only edges that contrast sharply with their surroundings; a lower value detects lower-contrast 
edges.

Frequency To specify the rate at which the lasso sets fastening points, enter a value between 0 and 100 for Frequency. 
A higher value anchors the selection border in place more quickly. 

On an image with well-defined edges, try a higher width and higher edge contrast, and trace the border roughly. On 
an image with softer edges, try a lower width and lower edge contrast, and trace the border more precisely.

Stylus Pressure If you are working with a stylus tablet, select or deselect the Stylus Pressure option. When the option 
is selected, an increase in stylus pressure decreases the edge width. 

5 Click in the image to set the first fastening point. Fastening points anchor the selection border in place.

6 To draw a freehand segment, either release or keep the mouse button depressed, and then move the pointer along 
the edge you want to trace. 

The most recent segment of the selection border remains active. As you move the pointer, the active segment snaps to 
the strongest edge in the image, based on the detection width set in the options bar. Periodically, the Magnetic Lasso 
tool adds fastening points to the selection border to anchor previous segments.

7 If the border doesn’t snap to the desired edge, click once to add a fastening point manually. Continue to trace the 
edge, and add fastening points as needed.

Fastening points anchor selection border to edges

8 To switch temporarily to the other lasso tools, do one of the following:

• To activate the Lasso tool, hold down Alt (Windows) or Option (Mac OS), and drag with the mouse button 
depressed.

• To activate the Polygonal Lasso tool, hold down Alt (Windows) or Option (Mac OS), and click.

9 To erase recently drawn segments and fastening points, press the Delete key until you’ve erased the fastening points 
for the desired segment. 

10 Close the selection border:

• To close the border with a freehand Magnetic segment, double-click, or press Enter or Return.

• To close the border with a straight segment, hold down Alt (Windows) or Option (Mac OS), and double-click.

• To close the border, drag back over the starting point and click.
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11 (Optional) Click Refine Edge to further adjust the selection boundary or view the selection against different 
backgrounds or as a mask. See “Refine selection edges” on page 262.

Select with the Quick Selection tool
You can use the Quick Selection tool  to quickly “paint” a selection using an adjustable round brush tip. As you 
drag, the selection expands outward and automatically finds and follows defined edges in the image.

1 Select the Quick Selection tool .

2 In the options bar, click one of the selection options: New, Add To, or Subtract From.

New is the default option if nothing is selected. After making the initial selection, the option changes automatically to 
Add to.

3 To change the Quick Selection tool brush tip size, click the Brush menu in the options bar and type in a pixel size 
or move the Diameter slider. Use the Size pop-up menu options to make the brush tip size sensitive to pen pressure 
or a stylus wheel.

When creating a selection, press the right bracket (]) to increase the Quick Selection tool brush tip size; press the left 
bracket ([) to decrease the brush tip size. 

4 Choose Quick Selection options.
Sample All Layers Creates a selection based on all layers instead of just the currently selected layer.

Auto-Enhance Reduces roughness and blockiness in the selection boundary. Auto-Enhance automatically flows the 
selection further toward image edges and applies some of the edge refinement you can apply manually in the Refine 
Edge dialog with the Smooth, Contrast, and Radius options.

5 Paint inside the part of the image you want to select. 

The selection grows as you paint. If updating is slow, continue to drag to allow time to complete work on the selection. 
As you paint near the edges of a shape, the selection area extends to follow the contours of the shape edge. 

Painting with the Quick Selection tool to extend the selection

If you stop dragging and then click or drag in a nearby area, the selection will grow to include the new area. 

• To subtract from a selection, click the Subtract from option in the options bar, then drag over the existing selection.

• To temporarily switch between add and subtract modes, hold down the Alt (Windows) or Option (Mac) key. 

• To change the tool cursor, choose Edit > Preferences > Cursors > Painting Cursors (Windows) or Photoshop > 
Preferences > Cursors > Painting Cursors (Mac OS). Normal Brush Tip displays the standard Quick Selection 
cursor with a plus or minus sign to show the selection mode. 
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6 (Optional) Click Refine Edge to further adjust the selection boundary or view the selection against different 
backgrounds or as a mask. See “Refine selection edges” on page 262.

Select with the Magic Wand tool
The Magic Wand tool lets you select a consistently colored area (for example, a red flower) without having to trace its 
outline. You specify the color range, or tolerance, for the Magic Wand tool’s selection, based on similarity to the pixel 
you click. 

You cannot use the Magic Wand tool on an image in Bitmap mode or on 32-bits-per-channel images. 

1 Select the Magic Wand tool .

2 Specify one of the selection options in the options bar. The Magic Wand tool’s pointer changes depending on which 
option is selected. 

Selection options
A. New  B. Add To  C. Subtract From  D. Intersect With  

3 In the options bar, specify any of the following:
Tolerance Determines the similarity or difference of the pixels selected. Enter a value in pixels, ranging from 0 to 255. 
A low value selects the few colors very similar to the pixel you click. A higher value selects a broader range of colors. 

Anti-aliased Creates a smoother-edged selection. 

Contiguous Selects only adjacent areas using the same colors. Otherwise, all pixels in the entire image using the same 
colors are selected.

Sample All Layers Selects colors using data from all the visible layers. Otherwise, the Magic Wand tool selects colors 
from the active layer only. 

4 In the image, click the color you want to select. If Contiguous is selected, all adjacent pixels within the tolerance 
range are selected. Otherwise, all pixels in the tolerance range are selected.

5 (Optional) Click Refine Edge to further adjust the selection boundary or view the selection against different 
backgrounds or as a mask. See “Refine selection edges” on page 262.

Select a color range
The Color Range command selects a specified color or color range within an existing selection or an entire image. If 
you want to replace a selection, be sure to deselect everything before applying this command. The Color Range 
command is not available for 32-bits-per-channel images.

To refine an existing selection, use the Color Range command repeatedly to select a subset of colors. For example, to 
select the green areas in a cyan selection, select Cyans in the Color Range dialog box, and click OK. Then reopen the 
Color Range dialog box, and select Greens. (The results are subtle because this technique selects parts of colors within 
a color mix.) 

1 Choose Select > Color Range. 

You can also use Color Range to refine a layer mask. See “Change mask opacity or refine edges” on page 326. 
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2 Choose the Sampled Colors tool from the Select menu.

You can also choose a color or tonal range from the Select menu, but you won’t be able to adjust the selection. 
The Out-Of-Gamut option works only on RGB and Lab images. (An out-of-gamut color is an RGB or Lab color that 
cannot be printed using process color printing.)

If you are selecting multiple color ranges in the image, select Localized Color Clusters to build a more accurate 
selection. 

3 Select one of the display options:
Selection Previews the selection that will result from the colors you sample in the image. By default, white areas are 
selected pixels, black areas are unselected, and gray areas are partially selected.

Image Previews the entire image. For example, you might want to sample from a part of the image that isn’t on-screen.

To toggle between the Image and Selection previews in the Color Range dialog box, press Ctrl (Windows) or Command 
(Mac OS). 

4 Position the Eyedropper pointer over the image or preview area, and click to sample the colors you want included. 

Sampling color

5 Adjust the range of colors selected using the Fuzziness slider or by entering a value. The Fuzziness setting controls 
how wide a range of colors is in the selection, and increases or decreases the amount of partially selected pixels (gray 
areas in the selection preview). Set a low Fuzziness value to restrict the color range, a higher value to increase the 
range.
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Increasing fuzziness expands selection

If you selected Localized Color Clusters, use the Range slider to control how far or near a color must be from the sample 
points to be included in the selection. For example, your image contains a patch of yellow flowers in both the 
foreground and the background, but you want to select just the foreground flowers. Sample the colors in the 
foreground flowers and reduce the Range so that the similarly colored flowers in the background are not selected.

6 Adjust the selection:

• To add colors, select the plus eyedropper, and click in the preview area or image.

• To remove colors, select the minus eyedropper, and click in the preview area or image.

To activate the plus eyedropper temporarily, hold down Shift. Hold down Alt (Windows) or Option (Mac OS) to 
activate the minus eyedropper.

7 To preview the selection in the image window, choose a Selection Preview option:
None Shows the original image.

Grayscale shows white for completely selected pixels, gray for partially selected ones, and black for unselected ones.

Black Matte Shows the original image for selected pixels, and black for unselected ones. This option is good for bright 
images.

White Matte Shows the original image for selected pixels, and white for unselected ones. This option is good for dark 
images.

Quick Mask shows unselected areas as a rubylith overlay (or a custom color you’ve specified in the Quick Mask 
Options dialog box).

8 To revert to the original selection, hold down Alt (Windows) or Option (Mac OS), and click Reset.

9 To save and load color range settings, use the Save and Load buttons in the Color Range dialog box to save and reuse 
the current settings.

Note:  If you see the message “No pixels are more than 50% selected,” the selection border will not be visible. You may 
have picked a color choice from the Select menu, such as Reds, when the image didn’t contain any red hues with high 
enough saturation.

For a video on making selections, see www.adobe.com/go/vid0002.

Adjusting pixel selections

Move, hide, or invert a selection
You can move a selection border around an image, hide a selection border, and invert a selection so that the previously 
unselected part of the image is selected.
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Note: To move the selection itself, not the selection border, use the Move tool. See “Move a selection” on page 265.

More Help topics 
“Apply transformations” on page 218

“Show or hide Extras” on page 40

Move a selection border
1 Using any selection tool, select New Selection  from the options bar, and position the pointer inside the selection 

border. The pointer changes  to indicate that you can move the selection.

2 Drag the border to enclose a different area of the image. You can drag a selection border partly beyond the canvas 
boundaries. When you drag it back, the original border reappears intact. You can also drag the selection border to 
another image window.

Original selection border (left), and selection border moved (right)

You can apply geometric transformations to change the shape of a selection border. 

Control the movement of a selection
• To constrain the direction to multiples of 45°, begin dragging, and then hold down Shift as you continue to drag. 

• To move the selection in 1-pixel increments, use an arrow key. 

• To move the selection in 10-pixel increments, hold down Shift, and use an arrow key.

Hide or show selection edges
Do one of the following:

• Choose View > Extras. This command shows or hides selection edges, grids, guides, target paths, slices, 
annotations, layer borders, count, and smart guide.

• Choose View > Show > Selection Edges. This toggles the view of the selection edges and affects the current selection 
only. The selection edges reappear when you make a different selection.

Select the unselected parts of an image
! Choose Select > Inverse.

You can use this option to select an object placed against a solid-colored background. Select the background using the 
Magic Wand tool and then inverse the selection. 

Adjust selections manually
You can use the selection tools to add to or subtract from existing pixel selections. 

Updated 1 October 2009



261USING PHOTOSHOP CS4
Selecting and masking

Before manually adding to or subtracting from a selection, you may want to set the feather and anti-aliasing values in 
the options bar to the same settings used in the original selection.

Add to a selection or select an additional area
1 Make a selection.

2 Using any selection tool, do one of the following: 

• Select the Add To Selection option  in the options bar, and drag to add to the selection.

• Hold down Shift, and drag to add to the selection.

A plus sign appears next to the pointer when you’re adding to a selection.

Subtract from a selection
1 Make a selection.

2 Using any selection tool, do one of the following:

• Select the Subtract From Selection option  in the options bar, and drag to intersect with other selections.

• Hold down Alt (Windows) or Option (Mac OS), and drag to subtract another selection.

A minus sign appears next to the pointer when you’re subtracting from a selection. 

Select only an area intersected by other selections
1 Make a selection.

2 Using any selection tool, do one of the following:

• Select the Intersect With Selection option  in the options bar, and drag.

• Hold down Alt+Shift (Windows) or Option+Shift (Mac OS) and drag over the portion of the original selection that 
you want to select.

An “x” appears next to the pointer when you’re selecting an intersected area. 

Intersected selections

Expand or contract a selection by a specific number of pixels
1 Use a selection tool to make a selection.

2 Choose Select > Modify > Expand or Contract. 

3 For Expand By or Contract By, enter a pixel value between 1 and 100, and click OK.

The border is increased or decreased by the specified number of pixels. Any portion of the selection border running 
along the canvas’s edge is unaffected. 
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Create a selection around a selection border
The Border command lets you select a width of pixels inside and outside an existing selection border. This can be useful 
when you need to select a border or band of pixels around an image area, rather than the area itself, for example to 
clean up a halo effect around a pasted object.

Original selection (left), and after Border command: 5 pixels (right)

1 Use a selection tool to make a selection.

2 Choose Select > Modify > Border. 

3 Enter a value between 1 and 200 pixels for the border width of the new selection, and click OK. 

The new selection frames the original selected area, and is centered on the original selection border. For example, a 
border width of 20 pixels creates a new, soft-edged selection that extends 10 pixels inside the original selection border 
and 10 pixels outside it. 

Expand a selection to include areas with similar color
Do one of the following:

• Choose Select > Grow to include all adjacent pixels falling within the tolerance range specified in the Magic Wand 
options. 

• Choose Select > Similar to include pixels throughout the image, not just adjacent ones, falling within the tolerance 
range. 

To increase the selection in increments, choose either command more than once.

Note: You cannot use the Grow and Similar commands on Bitmap mode images or 32-bits-per-channel images.

Clean up stray pixels in a color-based selection
1 Choose Select > Modify > Smooth. 

2 For Sample Radius, enter a pixel value between 1 and 100, and click OK. 

For each pixel in the selection, Photoshop examines the pixels around it, to the distance you specify in the radius 
setting. If more than half of these surrounding pixels are selected, the pixel remains in the selection, and the unselected 
pixels around it are added to the selection. If less than half the surrounding pixels are selected, the pixel is removed 
from the selection. The overall effect is to reduce patchiness and smooth sharp corners and jagged lines in the selection. 

Refine selection edges
The Refine Edge option improves the quality of a selection’s edges and allows you to view the selection against different 
backgrounds for easy editing. 
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You can also use Refine Edge options to refine a layer mask. See “Change mask opacity or refine edges” on page 326. 

1 Create a selection with any selection tool.

2 Click Refine Edge in the selection tool options bar or choose Select > Refine Edge to set options for adjusting the 
selection: 

Radius Determines the size of the region around the selection boundary in which edge refinement occurs. Increase the 
radius to create a more exact selection boundary in areas with soft transitions or fine detail, such as those in short hair 
or fur, or blurred boundaries.

Contrast Sharpens selection edges and removes fuzzy artifacts. Increasing contrast can remove excessive noise near 
selection edges caused by a high Radius setting. 

Smooth Reduces irregular areas (“hills and valleys”) in the selection boundary to create a smoother outline. Enter a 
value or move the slider from 0 to 100.

Feather Creates a soft-edged transition between the selection and its surrounding pixels. Enter a value or move the 
slider to define the width of the feathered edge from 0 to 250 pixels. 

Contract/Expand Shrinks or enlarges the selection boundary. Enter a value or move the slider to set the amount from 
0 to 100% to expand, 0 to -100% to contract. Most useful for making subtle adjustments to soft-edged selections. 
Shrinking the selection can help remove unwanted background colors from selection edges.

For images where the colors of the selected object are distinct from the background, try increasing the Radius, applying 
Contrast to sharpen edges, then adjusting the Contract/Expand slider. For grayscale images or images where the colors 

of the selected object and the background are very similar, try smoothing first, then the Feather option, then 
Contract/Expand.

3 Click a Selection View icon to change view modes. Click Description to view information about each mode. 

• Select or deselect Preview to turn edge refinement previewing on or off.

• Click the Zoom tool to zoom in or out while adjusting the selection.

• Use the Hand tool to reposition the image. 

Double-click the Quick Mask preview mode icon to change mask color or opacity.  

4 To save your selection adjustments, click OK.

Soften the edges of selections
You can smooth the hard edges of a selection by anti-aliasing and by feathering.

Anti-aliasing Smooths the jagged edges of a selection by softening the color transition between edge pixels and 
background pixels. Because only the edge pixels change, no detail is lost. Anti-aliasing is useful when cutting, copying, 
and pasting selections to create composite images.

Anti-aliasing is available for the Lasso tool, the Polygonal Lasso tool, the Magnetic Lasso tool, the Elliptical Marquee 
tool, and the Magic Wand tool. (Select a tool to display its options bar.) 

Note: You must specify this option before using these tools. After a selection is made, you cannot add anti-aliasing.

Feathering Blurs edges by building a transition boundary between the selection and its surrounding pixels. This 
blurring can cause some loss of detail at the edge of the selection.

You can define feathering for the Marquee tools, the Lasso tool, the Polygonal Lasso tool, or the Magnetic Lasso tool 
as you use the tool, or you can add feathering to an existing selection. 
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Note: Feathering effects become apparent only after you move, cut, copy, or fill the selection.

Select pixels using anti-aliasing
1 Select the Lasso tool, the Polygonal Lasso tool, the Magnetic Lasso tool, the Elliptical Marquee tool, or the Magic 

Wand tool.

2 Select Anti-aliased in the options bar.

Define a feathered edge for a selection tool
1 Select any of the lasso or marquee tools.

2 Enter a Feather value in the options bar. This value defines the width of the feathered edge and can range from 0 to 
250 pixels. 

Define a feathered edge for an existing selection
1 Choose Select > Modify > Feather.

2 Enter a value for the Feather Radius, and click OK. 

Note: A small selection made with a large feather radius may be so faint that its edges are invisible and thus not selectable. 
If you see the message “No pixels are more than 50% selected,” either decrease the feather radius or increase the size of the 
selection. Or click OK to accept the mask at its current setting and create a selection in which you cannot see the edges.

Selection without feathering and with feathering. 
A. Selection with no feather, same selection filled with pattern  B. Selection with feather, same selection filled with pattern  

Remove fringe pixels from a selection
When you move or paste an anti-aliased selection, some of the pixels surrounding the selection border are included 
with the selection. This can result in a fringe or halo around the edges of the pasted selection. These Matting 
commands let you edit unwanted edge pixels: 

• Defringe replaces the color of any fringe pixels with the color of pixels farther in from the edge of the selection that 
don’t contain the background color.

A

B
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• Remove Black Matte and Remove White Matte are useful when a selection is anti-aliased against a white or black 
background and you want to paste it onto a different background. For example, anti-aliased black text on a white 
background has gray pixels at the edges, which are visible against a colored background.

You can also remove fringe areas by using the Advanced Blending sliders in the Layer Styles dialog box to remove, 
or make transparent, areas from the layer. In this case, you would make the black or white areas transparent. Alt-

click (Windows) or Option-click (Mac OS) the sliders to separate them; separating the sliders allows you to remove 
fringe pixels and retain a smooth edge.

Decrease fringe on a selection 
1 Choose Layer > Matting > Defringe.

2 Enter a value in the Width box to specify the area in which to search for replacement pixels. In most cases, a distance 
of 1 or 2 pixels is enough.

3 Click OK.

Remove a matte from a selection
! Choose Layer > Matting > Remove Black Matte or Layer > Matting > Remove White Matte.

Moving and copying selected pixels

Move a selection
1 Select the Move tool . 

2 Move the pointer inside the selection border, and drag the selection to a new position. If you have selected multiple 
areas, all move as you drag.

Original selection (left), and after the selection is moved with the Move tool (right)

Copy selections
You can use the Move tool to copy selections as you drag them within or between images, or you can copy and move 
selections using the Copy, Copy Merged, Cut, and Paste commands. Dragging with the Move tool saves memory 
because the clipboard is not used as it is with the Copy, Copy Merged, Cut, and Paste commands.

Copy Copies the selected area on the active layer.

Copy Merged Makes a merged copy of all the visible layers in the selected area.

Paste Pastes a cut or copied selection into another part of the image or into another image as a new layer. If you have 
a selection, the Paste command places the copied selection over the current selection. Without an active selection, 
Paste places the copied selection in the middle of the view area.
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Paste Into Pastes a cut or copied selection inside another selection in the same image or a different image. The source 
selection is pasted onto a new layer, and the destination selection border is converted into a layer mask.

When a selection or layer is pasted between images with different resolutions, the pasted data retains its pixel 
dimensions. This can make the pasted portion appear out of proportion to the new image. Use the Image Size 
command to make the source and destination images the same resolution before copying and pasting, or use the Free 
Transform command to resize the pasted content.

Depending on your color management settings and the color profile associated with the file (or imported data), you 
may be prompted to specify how to handle color information in the file (or imported data).

More Help topics 
“About layer and vector masks” on page 323

“Set up color management” on page 134

Copy a selection
1 Select the area you want to copy.

2 Choose Edit > Copy, or Edit > Copy Merged.

Copy a selection while dragging
1 Select the Move tool , or hold down Ctrl (Windows) or Command (Mac OS) to activate the Move tool. 

2 Hold down Alt (Windows) or Option (Mac OS), and drag the selection you want to copy and move. 

When copying between images, drag the selection from the active image window into the destination image window. 
If nothing is selected, the entire active layer is copied. As you drag the selection over another image window, a border 
highlights the window if you can drop the selection into it.

Dragging a selection into another image

Create multiple copies of a selection within an image
1 Select the Move tool , or hold down Ctrl (Windows) or Command (Mac OS) to activate the Move tool.

2 Copy the selection:

• Hold down Alt (Windows) or Option (Mac OS), and drag the selection.

• To copy the selection and offset the duplicate by 1 pixel, hold down Alt or Option, and press an arrow key.

• To copy the selection and offset the duplicate by 10 pixels, press Alt+Shift (Windows) or Option+Shift (Mac OS), 
and press an arrow key.

As long as you hold down Alt or Option, each press of an arrow key creates a copy of the selection and offsets it by the 
specified distance from the last duplicate. In this case, the copy is made on the same layer.
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Paste one selection into another
1 Cut or copy the part of the image you want to paste. 

2 Select the part of the image into which you want to paste the selection. The source selection and the destination 
selection can be in the same image or in two different Photoshop images.

3 Choose Edit > Paste Into. The contents of the source selection appear within the destination selection. 

The Paste Into operation adds a layer and layer mask to the image. In the Layers panel, the new layer contains a layer 
thumbnail for the pasted selection next to a layer mask thumbnail. The layer mask is based on the selection you pasted 
into: the selection is unmasked (white), the rest of the layer is masked (black). The layer and layer mask are unlinked—
that is, you can move each one independently.

Using the Paste Into command
A. Window panes selected  B. Copied image  C. Paste Into command  D. Layer thumbnails and layer mask in Layers panel  E. Pasted image 
repositioned  

4 Select the Move tool , or hold down the Ctrl (Windows) or Command (Mac OS) key to activate the Move tool. 
Then drag the source contents until the part you want appears through the mask.

5 To specify how much of the underlying image shows through, click the layer mask thumbnail in the Layers panel, 
select a painting tool, and edit the mask:

• To hide more of the image underlying the layer, paint the mask with black.

• To reveal more of the image underlying the layer, paint the mask with white.

• To partially reveal the image underlying the layer, paint the mask with gray.

6 If you are satisfied with your results, you can choose Layer > Merge Down to merge the new layer and layer mask 
with the underlying layer and make the changes permanent.

A B
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Copy between applications
You can use the Cut, Copy, or Paste commands to copy selections from Photoshop and paste them into other 
applications, or to paste artwork from other applications into Photoshop. The cut or copied selection remains on the 
clipboard until you cut or copy another selection. You can also copy artwork between Photoshop and Illustrator by 
dragging and dropping.

In some cases, the contents of the clipboard are converted to a raster image. Photoshop prompts you when vector 
artwork will be rasterized. 

Note: The image is rasterized at the resolution of the file into which you paste it. Vector Smart Objects are not rasterized.

More Help topics 
“About Smart Objects” on page 315

“About file formats and compression” on page 461

“Remove fringe pixels from a selection” on page 264

Paste PostScript artwork from another application
1 In the supporting application, select your artwork, and choose Edit > Copy. 

2 Select the image into which you’ll paste the selection.

3 Choose Edit > Paste.

4 In the Paste dialog box, select from the following Paste As options: 
Smart Object Places the artwork in a new layer as a smart object. 

Pixels Rasterizes the artwork as it is pasted. Rasterizing converts mathematically-defined vector artwork to pixels. 

Paths Pastes the copy as a path in the Paths panel. When copying type from Illustrator, you must first convert it to 
outlines.

Shape Layer Creates a new shape layer that uses the path as a vector mask.

Note: When copying artwork from Adobe Illustrator, the default clipboard preferences in Illustrator may prevent the 
Paste dialog box from appearing in Photoshop. Select AICB in the File Handling and Clipboard area of the Preferences 
dialog box in Illustrator if you want the Paste options to appear when you paste the artwork into Photoshop.

5 If you chose Paste As Pixels in the previous step, you can choose Anti-aliased in the options bar to make a smooth 
transition between the edges of the selection and the surrounding pixels.

Note: You can use the Matting commands if you have already merged data and are trying to reextract the rasterized data. 

Save clipboard contents when you quit Photoshop
1 Do one of the following:

• (Windows) Choose Edit > Preferences > General. 

• (Mac OS) Choose Photoshop > Preferences > General. 

2 Select Export Clipboard to save any Photoshop contents to the clipboard when you quit Photoshop.
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Copy artwork by dragging and dropping
! Do one of the following:

• Drag one or more Illustrator vector objects into an open image in Photoshop. This creates a vector Smart Object 
layer in the image. Choose Layer > Smart Objects > Edit Content to reopen the content in Illustrator for editing.

• To copy the vector object as a path in Photoshop, hold down Ctrl (Windows) or Command (Mac OS) as you drag 
from Illustrator.

• To copy the contents of the currently selected layer in Photoshop to Illustrator, use the Move tool to drag the 
content from the Photoshop window into an open Illustrator document.

Deleting and extracting objects

Remove (cut) an object from a photo
1 In the Layers panel, select the layer containing the object you want to remove.

2 Using a selection tool, select the object you want to remove. 

3 If you need to refine the selection, click the Quick Mask Mode button  in the toolbox. Photoshop masks or 
covers the non-selected areas of the image in a translucent color. Select a brush and appropriate brush size in the 
options bar. Paint with black to add to the mask; paint with white to reveal more of the image.

4 To remove the selected object, choose Edit > Cut. 

Delete selected pixels
! Choose Edit > Clear, or press Backspace (Windows) or Delete (Mac OS). To cut a selection to the clipboard, choose 

Edit > Cut.

Deleting a selection on a background or on a layer with the Lock Transparency option selected in the Layers panel 
replaces the original location with the background color. Deleting a selection on a layer without Lock Transparency 
selected replaces the original area with the layer transparency.

Channels

About channels
Channels are grayscale images that store different types of information:

• Color information channels are created automatically when you open a new image. The image’s color mode 
determines the number of color channels created. For example, an RGB image has a channel for each color (red, 
green, and blue) plus a composite channel used for editing the image.

• Alpha channels store selections as grayscale images. You can add alpha channels to create and store masks, which 
let you manipulate or protect parts of an image.

• Spot color channels specify additional plates for printing with spot color inks.

An image can have up to 56 channels. All new channels have the same dimensions and number of pixels as the 
original image.
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The file size required for a channel depends on the pixel information in the channel. Certain file formats, including 
TIFF and Photoshop formats, compress channel information and can save space. The size of an uncompressed file, 
including alpha channels and layers, appears as the right-most value in the status bar at the bottom of the window 
when you choose Document Sizes from the pop-up menu.

Note: As long as you save a file in a format supporting the image’s color mode, the color channels are preserved. Alpha 
channels are preserved only when you save a file in Photoshop, PDF, TIFF, PSB, or raw formats. DCS 2.0 format 
preserves only spot channels. Saving in other formats may cause channel information to be discarded.

More Help topics 
“About spot colors” on page 495

“About masks and alpha channels” on page 274

Channels panel overview
The Channels panel lists all channels in the image—composite channel first (for RGB, CMYK, and Lab images). A 
thumbnail of the channel’s contents appears to the left of the channel name; the thumbnail is automatically updated 
as you edit the channel.

Channel types 
A. Color channels  B. Spot channels  C. Alpha channels  

Display the Channels panel
! Choose Windows > Channels.

Resize or hide channel thumbnails
! Choose Panel Options from the Channels panel menu. Click a thumbnail size or click None to turn off the display 

of thumbnails.

Viewing thumbnails is a convenient way of tracking channel contents; however, turning off the display of thumbnails 
can improve performance.

Show or hide a channel
You can use the Channels panel to view any combination of channels in the document window. For example, you can 
view an alpha channel and the composite channel together to see how changes made in the alpha channel relate to the 
entire image.

! Click in the eye column next to the channel to show or hide that channel. (Click the composite channel to view all 
default color channels. The composite channel is displayed whenever all the color channels are visible.)

A

B
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To show or hide multiple channels, drag through the eye column in the Channels panel. 

Show color channels in color
Individual channels are displayed in grayscale. In RGB, CMYK, or Lab images, you can view the individual channels 
in color. (In Lab images, only the a and b channels appear in color.) If more than one channel is active, the channels 
always appear in color.

You can change the default to show the individual color channels in color. When a channel is visible in the image, an 
eye icon  appears to its left in the panel. 

1 Do one of the following:

• In Windows, choose Edit > Preferences > Interface.

• In Mac OS, choose Photoshop > Preferences > Interface.

2 Select Show Channels in Color, and click OK.

Select and edit channels
You can select one or more channels in the Channels panel. The names of all selected, or active, channels are 
highlighted.

Selecting multiple channels 
A. Not visible or editable  B. Visible but not selected for editing  C. Selected for viewing and editing  D. Selected for editing but not viewing  

• To select a channel, click the channel name. Shift-click to select (or deselect) multiple channels. 

• To edit a channel, select it and then use a painting or editing tool to paint in the image. You can paint on only one 
channel at a time. Paint with white to add the selected channel’s color at 100% intensity. Paint with a value of gray 
to add the channel’s color at a lower intensity. Paint with black to fully remove the channel’s color.

Rearrange and rename alpha and spot channels
You can move alpha or spot channels above the default color channels only if the image is in Multichannel mode 
(Image > Mode > Multichannel). For information about that mode’s limitations, see “Multichannel mode” on 
page 112.

• To change the order of alpha or spot channels, drag the channel up or down in the Channels panel. When a line 
appears in the position you want, release the mouse button.

Note: Spot colors are overprinted in the order of their appearance from top to bottom in the Channels panel.

• To rename an alpha or spot channel, double-click the channel’s name in the Channels panel, and enter a new name.

B
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More Help topics 
“Create a new spot channel” on page 495

Duplicate channels
You can copy a channel and use it in the current image or another image.

Duplicate a channel
If you are duplicating alpha channels between images, the channels must have identical pixel dimensions. You cannot 
duplicate a channel to a Bitmap-mode image.

1 In the Channels panel, select the channel to duplicate.

2 Choose Duplicate Channel from the Channels panel menu.

3 Type a name for the duplicate channel.

4 For Document, do one of the following:

• Choose a destination. Only open images with pixel dimensions identical to the current image are available. To 
duplicate the channel in the same file, select the channel’s current file. 

• Choose New to copy the channel to a new image, creating a multichannel image containing a single channel. Type 
a name for the new image. 

5 To reverse the selected and masked areas in the duplicate channel, select Invert. 

Duplicate a channel in an image
1 In the Channels panel, select the channel you want to duplicate.

2 Drag the channel onto the Create New Channel button  at the bottom of the panel.

Duplicate a channel in another image
1 In the Channels panel, select the channel you want to duplicate.

2 Make sure that the destination image is open.

Note: The destination image does not have to have the same pixel dimensions as the duplicated channel.

3 Do one of the following:

• Drag the channel from the Channels panel into the destination image window. The duplicated channel appears at 
the bottom of the Channels panel.

• Choose Select > All, and then choose Edit > Copy. Select the channel in the destination image and choose Edit > 
Paste. The pasted channel overwrites the existing channel.

Split channels into separate images
You can split channels of flattened images only. Splitting channels is useful when you want to retain individual channel 
information in a file format that doesn’t preserve channels.

! To split channels into separate images, choose Split Channels from the Channels panel menu.

The original file is closed, and the individual channels appear in separate grayscale image windows. The title bars in 
the new windows show the original filename plus the channel. You save and edit the new images separately.
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Merge channels
Multiple grayscale images can be combined as the channels of a single image. The images you want to merge must be 
in grayscale mode, be flattened (have no layers), have the same pixel dimensions, and be open. The number of grayscale 
images you have open determines the color modes available when merging channels. For example, if you have three 
images open, you can merge them into an RGB image; if you have four images open, they can become a CMYK image.

If you are working with DCS files that have accidentally lost their links (and so cannot be opened, placed, or printed), 
open the channel files, and merge them into a CMYK image. Then re-save the file as a DCS EPS file. 

1 Open the grayscale images containing the channels you want to merge, and make one of the images active.

You must have more than one image open for the Merge Channels option to be available.

2 Choose Merge Channels from the Channels panel menu.

3 For Mode, choose the color mode you want to create. The number of channels appropriate for the mode appears 
in the Channels text box. 

4 If necessary, enter a number in the Channels text box. 

If you enter a number that is incompatible with the selected mode, Multichannel mode is automatically selected. This 
creates a multichannel image with two or more channels.

5 Click OK.

6 For each channel, make sure the image you want is open. If you change your mind about the image type, click Mode 
to return to the Merge Channels dialog box. 

7 If you are merging channels into a multichannel image, click Next, and select the remaining channels. 

Note: All channels of a multichannel image are alpha channels or spot channels.

8 When you have finished selecting channels, click OK. 

The selected channels are merged into a new image of the specified type, and the original images are closed without 
any changes. The new image appears in an untitled window. 

Note: You cannot split and recombine (merge) an image with spot color channels. The spot color channel will be added 
as an alpha channel.

Delete a channel 
You may want to delete spot or alpha channels you no longer need before saving an image. Complex alpha channels 
can substantially increase the disk space required for an image. 

! In Photoshop, select the channel in the Channels panel and do one of the following:

• Alt-click (Windows) or Option-click (Mac OS) the Delete icon .

• Drag the channel name in the panel to the Delete icon.

• Choose Delete Channel from the Channels panel menu.

• Click the Delete icon at the bottom of the panel, and then click Yes.

Note: When you delete a color channel from a file with layers, visible layers are flattened and hidden layers are discarded. 
This is done because removing a color channel converts the image to Multichannel mode, which does not support layers. 
An image isn’t flattened when you delete an alpha channel, a spot channel, or a quick mask.
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Saving selections and using masks

About masks and alpha channels
When you select part of an image, the area that is not selected is “masked”, or protected from editing. So, when you 
create a mask, you isolate and protect areas of an image as you apply color changes, filters, or other effects to the rest 
of the image. You can also use masks for complex image editing such as gradually applying color or filter effects to an 
image. 

Examples of masks 
A. Opaque mask used to protect the background and edit the butterfly  B. Opaque mask used to protect the butterfly and color the background  
C. Semitransparent mask used to color the background and part of the butterfly  

Masks are stored in alpha channels. Masks and channels are grayscale images, so you can edit them like any other 
image with painting tools, editing tools and filters. Areas painted black on a mask are protected, and areas painted 
white are editable. 

Use Quick Mask mode to convert a selection to a temporary mask for easier editing. The Quick Mask appears as a 
colored overlay with adjustable opacity. You can edit the Quick Mask using any painting tool or modify it with a filter. 
Once you exit Quick Mask mode the mask is converted back to a selection on the image.

To save a selection more permanently, you can store it as an alpha channel. The alpha channel stores the selection as 
an editable grayscale mask in the Channels panel. Once stored as an alpha channel, you can reload the selection at any 
time or even load it into another image.

Selection saved as an alpha channel in Channels panel

Note: You can mask or hide parts of a layer using a layer mask.

More Help topics 
“About layer and vector masks” on page 323

A B C
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Create a temporary quick mask
To use Quick Mask mode, start with a selection and then add to or subtract from it to make the mask. You can also 
create the mask entirely in Quick Mask mode. Color differentiates the protected and unprotected areas. When you 
leave Quick Mask mode, the unprotected areas become a selection.

Note: A temporary Quick Mask channel appears in the Channels panel while you work in Quick Mask mode. However, 
you do all mask editing in the image window.

1 Using any selection tool, select the part of the image you want to change.

2 Click the Quick Mask mode button  in the toolbox.

A color overlay (similar to a rubylith) covers and protects the area outside the selection. Selected areas are left 
unprotected by this mask. By default, Quick Mask mode colors the protected area using a red, 50% opaque overlay.

Selecting in Standard mode and Quick Mask mode 
A. Standard mode  B. Quick Mask mode  C. Selected pixels appear as white in channel thumbnail  D. Rubylith overlay protects area outside 
selection, and unselected pixels appear as black in channel thumbnail  

3 To edit the mask, select a painting tool from the toolbox. The swatches in the toolbox automatically become black 
and white. 

4 Paint with white to select more of an image (the color overlay is removed from areas painted with white). To 
deselect areas, paint over them with black (the color overlay covers areas painted with black). Painting with gray or 
another color creates a semitransparent area, useful for feathering or anti-aliased effects. (Semitransparent areas 
may not appear to be selected when you exit Quick Mask Mode, but they are.)
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Painting in Quick Mask mode 
A. Original selection and Quick Mask mode with green chosen as mask color  B. Painting with white in Quick Mask mode adds to the selection  
C. Painting with black in Quick Mask mode subtracts from the selection  

5 Click the Standard Mode button  in the toolbox to turn off the quick mask and return to your original image. 
A selection border now surrounds the unprotected area of the quick mask.

If a feathered mask is converted to a selection, the boundary line runs halfway between the black pixels and the white 
pixels of the mask gradient. The selection boundary indicates the transition between pixels that are less than 50% 
selected and those that are more than 50% selected.

6 Apply the desired changes to the image. Changes affect only the selected area.

7 Choose Select > Deselect to deselect the selection, or save the selection by choosing Select > Save Selection. 

You can convert this temporary mask to a permanent alpha channel by switching to standard mode and choosing 
Select > Save Selection.

More Help topics 
“About layer and vector masks” on page 323

Change Quick Mask options
1 Double-click the Quick Mask Mode button  in the toolbox.

2 Choose from the following display options:
Masked Areas Sets masked areas to black (opaque) and selected areas to white (transparent). Painting with black 
increases the masked area; painting with white increases the selected area. When this option is selected, the Quick 
Mask button in the toolbox becomes a white circle on a gray background .
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Selected Areas Sets masked areas to white (transparent) and selected areas to black (opaque). Painting with white 
increases the masked area; painting with black increases the selected area. When this option is selected, the Quick Mask 
button in the toolbox becomes a gray circle on a white background .

To toggle between the Masked Areas and Selected Areas options for quick masks, Alt-click (Windows) or Option-click 
(Mac OS) the Quick Mask Mode button.

3 To choose a new mask color, click the color box, and choose a new color.

4 To change the opacity, enter a value between 0% and 100%. 

Both the color and opacity settings affect only the appearance of the mask and have no effect on how underlying areas 
are protected. Changing these settings may make the mask more easily visible against the colors in the image.

More Help topics 
“Choose a color with the Adobe Color Picker” on page 121

Create and edit alpha channel masks
You can create a new alpha channel and then use painting tools, editing tools, and filters to create a mask from the 
alpha channel. You can also save an existing selection in a Photoshop image as an alpha channel that appears in the 
Channels panel. See “Save and load selections” on page 278.

More Help topics 
“About channels” on page 269

Create an alpha channel mask using current options
1 Click the New Channel button  at the bottom of the Channels panel.

2 Paint on the new channel to mask out image areas.

Select areas of the image before you create the channel for the mask. Then paint on the channel to refine the mask. 

Create an alpha channel mask and set options
1 Alt-click (Windows) or Option-click (Mac OS) the New Channel button at the bottom of the Channels panel, or 

choose New Channel from the Channels panel menu.

2 Specify options in the New Channel dialog box.

3 Paint on the new channel to mask out image areas.

Channel options
To change options for an existing channel, double-click the channel thumbnail in the Channels panel or select Channel 
options from the Channels panel menu. 

Options available in the New Channel and Channel Options dialog boxes:

Masked areas Sets masked areas to black (opaque) and selected areas to white (transparent). Painting with black 
increases the masked area; painting with white increases the selected area. When this option is selected, the Quick 
Mask button in the toolbox becomes a white circle on a gray background .

Selected Areas Sets masked areas to white (transparent) and selected areas to black (opaque). Painting with white 
increases the masked area; painting with black increases the selected area. When this option is selected, the Quick Mask 
button in the toolbox becomes a gray circle on a white background .
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Spot Color Converts an alpha channel to a spot color channel. Only available for existing channels.

Color Sets the color and opacity of the mask. Click the color field to change the color. The color and opacity settings 
affect only the appearance of the mask and have no effect on how underlying areas are protected. Changing these 
settings may make the mask more easily visible against the colors in the image.

Paint on a channel to mask image areas
When the new channel appears at the bottom of the Channels panel, it is the only channel visible in the image window. 
Click the eye icon  for the composite color channel (RGB, CMYK) to display the image with a color overlay showing 
the mask.

! Select the brush or an editing tool and do one of the following to add or subtract from the mask created from the 
alpha channel: 

• To remove areas in the new channel, paint with white.

• To add areas in the new channel, paint with black.

• To add or remove areas using opacities less than 100%, set the Opacity in the options bar of the painting or editing 
tool and then paint with white or black. You can also paint with a color to achieve lower opacities.

Save and load selections
You can save any selection as a mask in a new or existing alpha channel and later reload the selection from the mask.

You can use a selection as a layer mask by loading the selection to make it active, then adding a new layer mask.

More Help topics 
“Add layer masks” on page 325

Save a selection to a new channel
1 Select the area or areas of the image you want to isolate.

2 Click the Save Selection button  at the bottom of the Channels panel. A new channel appears, named according 
to the sequence in which it was created.

Save a selection to a new or existing channel 
1 Use a selection tool to select the area or areas of the image you want to isolate. 

2 Choose Select > Save Selection.

3 Specify the following in the Save Selection dialog box, and click OK:
Document Chooses a destination image for the selection. By default, the selection is placed in a channel in your active 
image. You can choose to save the selection to a channel in another open image with the same pixel dimensions or to 
a new image.

Channel Chooses a destination channel for the selection. By default, the selection is saved in a new channel. You can 
choose to save the selection to any existing channel in the selected image or to a layer mask if the image contains layers. 

4 If you’re saving the selection as a new channel, type a name for the channel in the Name text box.

5 If you’re saving the selection to an existing channel, select how to combine the selections:
Replace Channel Replaces the current selection in the channel.

Add to Channel Adds the selection to the current channel contents.

Updated 1 October 2009



279USING PHOTOSHOP CS4
Selecting and masking

Subtract From Channel Deletes the selection from the channel contents.

Intersect With Channel Keeps the areas of the new selection that intersect with the channel contents.

You can select the channel from the Channels panel to see the saved selection displayed in grayscale.

Load a saved selection from the Channels panel
You can reuse a previously saved selection by loading it into an image. You can also load the selection into an image 
after you finish modifying an alpha channel. 

! Do one of the following in the Channels panel:

• Select the alpha channel, click the Load Selection button  at the bottom of the panel, and then click the composite 
color channel near the top of the panel.

• Drag the channel containing the selection you want to load onto the Load Selection button.

• Ctrl-click (Windows) or Command-click (Mac OS) the channel containing the selection you want to load.

• To add the mask to an existing selection, press Ctrl+Shift (Windows) or Command+Shift (Mac OS), and click the 
channel.

• To subtract the mask from an existing selection, press Ctrl+Alt (Windows) or Command+Option (Mac OS), and 
click the channel.

• To load the intersection of the saved selection and an existing selection, press Ctrl+Alt+Shift (Windows) or 
Command+Option+Shift (Mac OS), and select the channel.

You can drag a selection from one open Photoshop image into another. 

Load a saved selection
Note: If you are loading a saved selection from another image, make sure to open it. Also, make sure your destination 
image is active.

1 Choose Select > Load Selection. 

2 Specify the Source options in the Load Selection dialog box:
Document Chooses the source to load.

Channel Chooses the channel containing the selection you want to load.

Invert Selects the non-selected areas. 

3 Select an Operation option to specify how to combine the selections if the image already has a selection:
New Selection Adds the loaded selection. 

Add To Selection Adds the loaded selection to any existing selections in the image. 

Subtract From Selection Subtracts the loaded selection from existing selections in the image.

Intersect With Selection Saves a selection from an area intersected by the loaded selection and existing selections in 
the image.

You can drag a selection from one open Photoshop image into another. 
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Channel calculations

Blending layers and channels
You can use the blending effects associated with layers to combine channels within and between images into new 
images. You can use either the Apply Image command (on single and composite channels) or the Calculations 
command (on single channels). These commands offer two additional blending modes not available in the Layers 
panel—Add and Subtract. Although it’s possible to create new combinations of channels by copying channels to layers 
in the Layers panel, you may find it quicker to use the calculation commands to blend channel information. 

The calculation commands perform mathematical operations on the corresponding pixels of two channels (the pixels 
with identical locations in the image) and then combine the results in a single channel. Two concepts are fundamental 
to understanding how the calculation commands work.

• Each pixel in a channel has a brightness value. The Calculations and Apply Image commands manipulate these 
values to produce the resulting composite pixels. 

• These commands overlay the pixels in two or more channels. Thus, the images used for calculations must have the 
same pixel dimensions.

Blend channels with the Apply Image command
The Apply Image command lets you blend one image’s layer and channel (the source) with a layer and channel of the 
active image (the destination). 

1 Open the source and destination images, and select the desired layer and channel in the destination image. The 
pixel dimensions of the images must match for image names to appear in the Apply Image dialog box.

Note: If the color modes of the two images differ (for example, one image is RGB and the other is CMYK), you can apply 
a single channel (but not the source’s composite) to the destination layer’s composite channel. 

2 Choose Image > Apply Image.

3 Choose the source image, layer, and channel you want to combine with the destination. To use all layers in the 
source image, select Merged For Layer. 

4 To preview the results in the image window, select Preview.

5 To use the negative of the channel contents in the calculation, select Invert.

6 For Blending, choose a blending option.

For information on the Add and Subtract options, see “Add and Subtract blending modes” on page 281. For 
information on other blending options, see “List of blending modes” on page 351.

7 Enter an Opacity value to specify the effect’s strength. 

8 To apply the results only to opaque areas in the result layer, select Preserve Transparency.

9 If you want to apply the blending through a mask, select Mask. Then choose the image and layer containing the 
mask. For Channel, you can choose any color or alpha channel to use as the mask. You can also use a mask based 
on the active selection or the boundaries of the chosen layer (Transparency). Select Invert to reverse the masked 
and unmasked areas of the channel.
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Blend channels with the Calculations command
The Calculations command lets you blend two individual channels from one or more source images. You can then 
apply the results to a new image or to a new channel or selection in the active image. You cannot apply the Calculations 
command to composite channels.

1 Open the source image or images. 

Note: If you are using more than one source image, the images must have the same pixel dimensions.

2 Choose Image > Calculations. 

3 To preview the results in the image window, select Preview.

4 Choose the first source image, layer, and channel. To use all the layers in the source image, choose Merged For 
Layer. 

5 To use the negative of the channel contents in the calculation, select Invert. For Channel, choose Gray if you want 
to duplicate the effect of converting the image to grayscale.

6 Choose the second source image, layer, and channel, and specify options. 

7 For Blending, choose a blending mode. 

For information on the Add and Subtract options, see “Add and Subtract blending modes” on page 281. For 
information on other blending options, see “List of blending modes” on page 351.

8 Enter an Opacity value to specify the effect’s strength. 

9 If you want to apply the blending through a mask, select Mask. Then choose the image and layer containing the 
mask. For Channel, you can choose any color or alpha channel to use as the mask. You can also use a mask based 
on the active selection or the boundaries of the chosen layer (Transparency). Select Invert to reverse the masked 
and unmasked areas of the channel.

10 For Result, specify whether to place the blending results in a new document or in a new channel or selection in the 
active image. 

Add and Subtract blending modes 
The Add and Subtract blending modes are available only for the Apply Image and Calculations commands. 

Add
Adds the pixel values in two channels. This is a good way to combine non-overlapping images in two channels.

Because higher pixel values represent lighter colors, adding channels with overlapping pixels lightens the image. Black 
areas in both channels remain black (0 + 0 = 0). White in either channel results in white (255 + any value = 255 or 
greater).

Add mode divides the sum of the pixel values by the Scale amount, and then adds the Offset value to the sum. For 
example, to find the average of the pixels in two channels, add them, divide by 2, and enter no Offset value.

The Scale factor may be any number between 1.000 and 2.000. Entering a higher Scale value darkens the image. 

The Offset value lets you lighten or darken the pixels in the destination channel by any brightness value between +255 
and –255. Negative values darken the image; positive values lighten the image. 
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Subtract
Subtracts the pixel values in the source channel from the corresponding pixels in the target channel. As with Add 
mode, the result is then divided by the Scale factor and added to the Offset value.

The Scale factor may be any number between 1.000 and 2.000. The Offset value lets you lighten or darken the pixels in 
the destination channel by any brightness value between +255 and –255.
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Chapter 10: Layers

Layers are the building blocks of many image creation workflows. You may not need to work with layers if you are 
doing simple image adjustments, but layers help you work efficiently and are essential to most nondestructive image 
editing.

Layer basics

About layers
Photoshop layers are like sheets of stacked acetate. You can see through transparent areas of a layer to the layers below. 
You move a layer to position the content on the layer, like sliding a sheet of acetate in a stack. You can also change the 
opacity of a layer to make content partially transparent.

Transparent areas on a layer let you see layers below.

You use layers to perform tasks such as compositing multiple images, adding text to an image, or adding vector graphic 
shapes. You can apply a layer style to add a special effect such as a drop shadow or a glow. 

Work non-destructively
Sometimes layers don’t contain any apparent content. For example, an adjustment layer holds color or tonal 
adjustments that affect the layers below it. Rather than edit image pixels directly, you can edit an adjustment layer and 
leave the underlying pixels unchanged.

A special type of layer, called a Smart Object, contains one or more layers of content. You can transform (scale, skew, 
or reshape) a Smart Object without directly editing image pixels. Or, you can edit the Smart Object as a separate image 
even after placing it in a Photoshop image. Smart Objects can also contain smart filter effects, which allow you to apply 
filters non-destructively to images so that you can later tweak or remove the filter effect. See “Nondestructive editing” 
on page 314.

Organize layers
A new image has a single layer. The number of additional layers, layer effects, and layer sets you can add to an image 
is limited only by your computer’s memory. 

You work with layers in the Layers panel. Layer groups help you organize and manage layers. You can use groups to 
arrange your layers in a logical order and to reduce clutter in the Layers panel. You can nest groups within other 
groups. You can also use groups to apply attributes and masks to multiple layers simultaneously.
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